Increased response times in eu-west-3 - mitgated and fix in progress
Minor incident
ImageEngine Services
ImageEngine CDN
2026-03-23 07:52 EDT
· 4 hours, 38 minutes
Updates
Issue
March 23, 2026 · 12:30 EDT
Our technical team resolved the increased response times in the eu-west-3 region by 12:30pm ET on 2026-03-23 (16:30pm UTC). The fix is beying deployed across regions preventatively.
Issue
March 23, 2026 · 11:30 EDT
At approx 7:52am ET today 2026-03-23 (11:52am UTC) we identified an issue with increased image load times in our eu-west-3 region. Our technical team has been mitigating the impact, and is currently deploying a fix to the affected region.
← Back