Middle East Region — Traffic Rerouted
Minor incident
ImageEngine Services
ImageEngine CDN
2026-03-24 13:12 EDT
· 1 day, 22 hours, 10 minutes
Updates
Resolved
March 26, 2026 · 11:20 EDT
Due to instability in the Middle East Regions we have decided to serve this traffic from nearby regions.
Monitoring
March 24, 2026 · 13:12 EDT
The ongoing conflict in the Middle East has affected both Availability Zones in me-south-1.
Traffic has been shifted to established fallback region, until conditions stabilize.
Reference: https://www.aboutamazon.com/news/aws-bahrain-region-middle-east-conflict
← Back